[Distutils] Package install failures in 2.6.3 - setuptools vs Distribute

Zooko Wilcox-O'Hearn zooko at zooko.com
Mon Oct 5 18:13:52 CEST 2009

On Monday,2009-10-05, at 8:11 , Tarek Ziadé wrote:

> So are you saying that in an environment where you are allowed to  
> install Python 2.6.3, you will not be allowed to install an  
> hypothetical setuptools-0.6c10 (or a Distribute 0.6.3) ?

Yes, situations like that can come up.  For example, I guess the  
packaging of my own Tahoe-LAFS project is a case in point.  The  
current requirements for Tahoe-LAFS are Python >= 2.4.2 and < 3.0,  
and the source distribution of Tahoe-LAFS comes with its own bundled  
copy of setuptools.  We haven't finished our qualification of  
Distribute so we're not ready to switch our build system to  
Distribute.  Setuptools-0.6c10 is hypothetical at this point.  What  
do we do?  We could tighten the Python version to >= 2.4.2 and <=  
2.6.2.  We could develop and test a patch to our bundled copy of  
setuptools to work-around this problem.  We could ask the open source  
volunteer who is testing Distribute for us to "hurry up".  We could  
ask PJE to "hurry up" and release a new version of setuptools.    
Perhaps we will end up doing more than one of these things.

Many of our users won't even be able to diagnose the problem if they  
upgrade from Python 2.6.2 to 2.6.3 and the install breaks.  They  
won't know what is wrong or how to work around it, other than by  
writing to our mailing list asking for help.

The faster this gets fixed and the more "lenient" Python 2.6.x is  
with respect to what versions of setuptools/Distribute it requires  
and the more "lenient" setuptools and Distribute are with respect to  
what version of Python they require, the better for everyone.

Thank you kindly for your attention.



More information about the Distutils-SIG mailing list