[Distutils] [buildout] RFC: buildout support for distribute

Tarek Ziadé ziade.tarek at gmail.com
Tue Oct 13 21:53:03 CEST 2009

2009/10/13 P.J. Eby <pje at telecommunity.com>:
> At 09:25 PM 10/13/2009 +0200, Tarek Ziadé wrote:
>> Notice that the current trunk of Distribute is now changing any
>> 'setuptools'
>> requirement that is tiggered using "Requirement.parse" and "resolve" APIs
>> into
>> a 'distribute' one.
> Please note that this change will cause problems for people in the future,
> as new features are introduced in the 0.7a1 line.  The earlier version of
> this hack, which only ignored requests for older versions of setuptools,
> would not have caused such a problem.
> I would suggest that Distribute should only silently ignore requests for
> versions of setuptools that it can explicitly emulate; other requests should
> result in an error, so that a problem cannot pass silently.
> Otherwise, a package depending on new features in the 0.7 line will silently
> fail when those features are not present in its operating environment.

Ok sure, makes sense. We will return 'distribute' only if 'setuptools'
is from the 0.6.x series
and below.

More information about the Distutils-SIG mailing list