[Distutils] setuptools 0.6c10 delayed until Monday

Reinout van Rees reinout at vanrees.org
Sat Oct 17 04:03:10 CEST 2009

On 2009-10-16, P.J. Eby <pje at telecommunity.com> wrote:
> Also, this will give those who are using Distribute and do *not* wish 
> to use this release, a chance to upgrade to the latest version of 
> Distribute first.  (Which, if I understand correctly, includes code 
> to prevent accidental re-installation of setuptools.)

Correct.  There's an "if" in the one or two places where a requirement is
looked up.  If the request is for "setuptools", distribute will reply with
"here you go, here's distribute".  So that ought to work.


I added the code that checks whether we're not requesting a 0.7-series
setuptools.  So if a 0.7a1 setuptools comes out and someone requires it, it
will be installed: distribute won't fake a 0.7.  And I added a similar check
in the (from the top of my head) on_insert() method that raises an error if
you try to install a 0.7 setuptools inside a distribute-handled working set
(like you suggested, iirc).


Reinout van Rees - reinout at vanrees.org - http://reinout.vanrees.org
Software developer at http://www.thehealthagency.com
"Military engineers build missiles. Civil engineers build targets"

More information about the Distutils-SIG mailing list