[Distutils] Brand new, clean server, set up from scratch, buildbot still fails

Tarek Ziadé ziade.tarek at gmail.com
Mon Oct 19 09:34:58 CEST 2009

On Mon, Oct 19, 2009 at 4:35 AM, Steve Steiner <ssteiner at mac.com> wrote:
> http://pastebin.com/m69796bc5

sounds like version problems.

> This is running on a bare system, after figuring out which development tools
> were needed, all the version control systems necessary etc.  I have all that
> captured in my Fabric script so we're all set for being able to duplicate
> it.
> I have NOT installed anything into the system Python at all.  In fact, other
> than the tools necessary to pull the products out of VCS, and the compilers
> and such, I haven't installed (or done) anything to the system at all.
>  That's kind of the point.  We want to be able to go from bare metal to
> running buildbot completely automatically.

I tried to build the buildbot again on debian and Mac OSX and it worked fine
Didn't try on Ubuntu though.

It seems that it's using the buildbot installed in your system, which
might be the problem
since the buildout doesn't pinpoint the versions.

Here, I use Python 2.6 and I have:
 - buildbot-0.7.11p3
- Twisted-8.2.0
- collective.buildbot-0.3.5

I suggest that you install virtualenv and that your run this sequence
in an Ubuntu that has
all the development tools we have discussed (python-dev, zlib, etc) :

$ cd /var/
$ mkdir distutils-bot
$ cd distutils-bot
$ virtualenv --no-site-packages .
$ hg clone https://tarek@bitbucket.org/tarek/distutils-builbot .
$ bin/python bootstrap.py
$ bin/buildout -c buildbot.cfg

This is supposed to compile.

Last option: give me an ssh access to your ubuntu box if possible,
I'll probaby be able to fix it.


More information about the Distutils-SIG mailing list