[Distutils] distribute doesn't use pip?

Tom Davis tom at recursivedream.com
Fri Jan 29 22:41:30 CET 2010

First, allow me to apologize in advance if this isn't the right place 
for this question. I found this mailing list from the distribute docs, 
but I'm not sure that it's a general support mailing list.

I've read through the distribute docs and either something isn't working 
correctly or my understanding is off. I created a virtualenv using the 
--distribute flag and annotated my setup.py file with the call to 
use_setuptools(). I passed the install_requires argument to setup(), 
including the impossible-to-install-via-easy_install package numpy. My 
understanding was that distribute uses pip instead of the stock 
easy_install, but this does not appear to be the case because "python 
setup.py install" still fails to install numpy, dying with the same 
exception that easy_install always throws. I tried a simple "pip install 
numpy" and it worked, as expected.

Am I missing something? Was distribute never meant to use pip over 
easy_install? Is there someway to flag a package as " 
--single-version-externally-managed"? Am I pretty much doomed in the 
case of wanting to handle the numpy dependency via setup.py?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20100129/6ca65c35/attachment.htm>

More information about the Distutils-SIG mailing list