[Distutils] How to force installing setuptools instead of distribute ?

P.J. Eby pje at telecommunity.com
Thu Jul 1 04:23:57 CEST 2010

At 11:10 AM 7/1/2010 +0900, David Cournapeau wrote:
>Ubuntu Lucid uses distribute instead of setuptools, and I cannot
>manage to use setuptools with virtualenv because of this. I upgraded
>to the last version of virtualenv, which claims to install setuptools
>by default, but I still get distribute instead, and I would guess this
>is because of Ubuntu using distribute, but who knows....
>Is there a simple way to force virtualenv to install setuptools (the
>PJE version, *not* the distribute fork) ?

Have you tried requesting an exact version number of setuptools? 
(e.g. setuptools==0.6c11 or setuptools==dev06)

(Distribute uses a hack of pkg_resources to pretend that it satisfies 
requirements that specify "setuptools".  However, I don't think it 
fakes what *version* of setuptools it pretends to be.)

More information about the Distutils-SIG mailing list