[Distutils] [buildout] buildout 1.5 sometime ever please?

Dave Peticolas dave at krondo.com
Tue Jul 13 01:59:54 CEST 2010

On Thu, Jul 8, 2010 at 8:58 AM, Gary Poster <gary.poster at canonical.com>wrote:

> My apologies.
> There is a branch that addresses all reported issues (as reported here and
> in Launchpad) except one: svn+ssh://
> svn.zope.org/repos/main/zc.buildout/branches/gary-betafix/ (or browse in
> http://svn.zope.org/zc.buildout/branches/gary-betafix/).
> Most notably, virtualenv users will have the pre-1.5 behavior.  The
> automated tests for this are ugly, but exist.
> The remaining reported bug is from Lennart Regebro.  I will include his
> original message at the end of the email.
> Once that is done, I would prefer another beta release.  The problems after
> the last beta release affected many people.  As Tarek mentioned, we do not
> have a real way to make a beta release, given the current bootstrap.py *and*
> how it is often used as an svn external.  Some people also do not specify a
> buildout version, so changing PyPI will immediately affect them.  I have not
> seen a solution that I believe will actually both provide isolation and
> encourage people to try the beta out easily.
> This situation has been a demotivator for me.  I can't even merge my branch
> without effect, because it will force some people to change their
> bootstrap.py scripts.  I don't want to do that until I have some time in my
> schedule cleared out to deal with possible fallout.
> That, combined with being very busy, is all my excuse, for what it is
> worth.
> In any case, to repeat and sum, the following remains:
> - Identify and fix the problem reported by Lennart (below).
> - Ideally, encourage people to try out the code in a controlled
> environment.  In order for this to not be a "release" in any way, people
> will have to manually use the new bootstrap if they want the new isolation,
> because I can't merge to trunk without effect; and will have to somehow get
> a new buildout distribution.  I've toyed with allowing it for download on
> Launchpad, or with putting it in PyPI with a b0 designation.
> - Make a release
> - (Deal with any remaining fallout)
> If someone helped with Lennart's bug, that would be great.
> If several someones volunteered to help test some kind of manual "beta"
> release, that would be great.

I'm testing out the beta branch and running into a problem. I'm running
buildout from a virtualenv,
and when I try to install the 'superlance' package, I get this:

  The required version of setuptools (>=0.6c9) is not available, and
  can't be installed while this script is running. Please install
  a more recent version first, using 'easy_install -U setuptools'.

  (Currently using setuptools 0.6c8 (/usr/lib/python2.5/site-packages))
  error: Setup script exited with 2

This is despite the fact that I have 0.6c11 installed in the virtualenv.
This seems to be caused
by the fact that the buildout bin script has this:

  import sys
  sys.path[0:0] = [

And thus picks up the older version of setuptools in /usr/lib/python2.5. I
tried removing those lines,
but buildout seems to be re-creating that file when I run it.

Any suggestions?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20100712/d6bfd605/attachment-0001.html>

More information about the Distutils-SIG mailing list