[Distutils] [issue111] Windows: easy_install tries to download X11 PyQT

P.J. Eby pje at telecommunity.com
Wed Jul 14 00:04:24 CEST 2010


FYI, PyQT can't be easy_installed, period, because it's not a 
distutils-based package.  Even if you downloaded the correct version 
(either manually or by giving the exact URL to easy_install), it 
still wouldn't work, and there's nothing that can be done about it on 
the easy_install side.  Sorry.

At 07:06 PM 7/13/2010 +0000, Erik Hahn wrote:
>On Windows, easy_install tries to install the X11 version of PyQT:
>
>D:\code>c:\Python26\Scripts\easy_install.exe pyqt
>install_dir C:\Python26\Lib\site-packages\
>Searching for pyqt
>Reading http://pypi.python.org/simple/pyqt/
>Reading http://www.riverbankcomputing.com/software/pyqt/
>Reading http://www.riverbankcomputing.com/software/pyqt/download
>Best match: PyQt x11-gpl-4.7.4
>Downloading 
>http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gp
>l-4.7.4.tar.gz
>Processing PyQt-x11-gpl-4.7.4.tar.gz
>error: Couldn't find a setup script in 
>c:\dokume~1\erik\lokale~1\temp\easy_insta
>ll-qycl5v\PyQt-x11-gpl-4.7.4.tar.gz



More information about the Distutils-SIG mailing list