[Distutils] Buildout not working with Bash wrapper for `python'

Gustavo Narea gustavonarea at 2degreesnetwork.com
Mon Jun 21 10:57:02 CEST 2010


On -10/01/37 20:59, Arfrever Frehtes Taifersar Arahesis wrote:
>> Linux requires that the interpreter be a real executable and won't accept a script there.
> Linux supports interpreters being scrips since 2.6.28.
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=bf2a9a39639b8b51377905397a5005f444e9a892

I don't know if Debian backported that, but our servers run 2.6.26 and
this works like a charm.

Anyway, the problem is that some packages (not all) cannot be installed
by Buildout when the wrapper is in use. I've investigated to see what
those packages have in common, but I haven't been able to find anything.

One of those packages is django-audit:

Do you have any idea why this is failing?

Thanks in advance.

Gustavo Narea.
Software Developer.
2degrees, Ltd. <http://www.2degreesnetwork.com/>.

More information about the Distutils-SIG mailing list