[Distutils] Buildout: Version conflicts with system-wide libraries

Gustavo Narea gustavonarea at 2degreesnetwork.com
Thu Mar 11 16:32:43 CET 2010


On my Ubuntu desktop, httplib2 v0.4.0 is installed system-wide because
it's required by many things. However, I need to use v0.6.0 of that
package in my Buildout-powered project.

But when I run Buildout, I get this error:
VersionConflict: (httplib2 0.4.0 (/usr/lib/pymodules/python2.5),

I've hit this problem before and what I had done is to remove the
system-wide install, which I cannot do this time.

There has to be a way for Buildout to ignore the global install, but I
could not find the answer after reading the documentation.

Can you please help me?


Gustavo Narea.
Software Developer.
2degrees, Ltd. <http://www.2degreesnetwork.com/>.

More information about the Distutils-SIG mailing list