[Distutils] Buildout: Version conflicts with system-wide libraries

Martin Aspeli optilude+lists at gmail.com
Thu Mar 11 17:14:52 CET 2010

Jim Fulton wrote:
> On Thu, Mar 11, 2010 at 10:32 AM, Gustavo Narea
> <gustavonarea at 2degreesnetwork.com>  wrote:
>> Hello,
>> On my Ubuntu desktop, httplib2 v0.4.0 is installed system-wide because
>> it's required by many things. However, I need to use v0.6.0 of that
>> package in my Buildout-powered project.
>> But when I run Buildout, I get this error:
>> =====
>> VersionConflict: (httplib2 0.4.0 (/usr/lib/pymodules/python2.5),
>> Requirement.parse('httplib2==0.6.0'))
>> =====
>> I've hit this problem before and what I had done is to remove the
>> system-wide install, which I cannot do this time.
>> There has to be a way for Buildout to ignore the global install, but I
>> could not find the answer after reading the documentation.
>> Can you please help me?
> There isn't currently an option to get buildout to ignore
> site-packages, although an option to do that is under review.
> Many of us simply avoid using system Python installs.  I personally
> always have clean Python installs, independent from system Python,
> that I use for applications.

I hope you merge that option ASAP. :)

The problem is not "us" who have pristine global Python's. It's "them" 
that we give our buildouts to and expect them to work the same as they 
did on our own machine: end users (Plone's installers are buildouts now, 
for example), sysadmins, and new developers.


More information about the Distutils-SIG mailing list