[Distutils] setuptools dependencies failure and wildcards

Nicholas Bower nick at petangent.net
Sun Mar 14 11:16:32 CET 2010


I have the following simple dependencies using setuptools;

      install_requires=['shapely==1.0.14','sqlalchemy==0.5.8'],

Two questions;

1) Shapely will not work.  The available packages are;

Shapely-1.0.14.win32.py24.exe (md5).
Shapely-1.0.14.win32.py25.exe (md5).
Shapely-1.0.14.win32.py26.exe (md5).

but python version is not being appended as below.  Is shapely thus
incompatible with setuptools?  If so, what are the name conventions
the author should be using and when does setuptools try for the
current python version only?

Searching for shapely==1.0.14
Reading http://pypi.python.org/simple/shapely/
Reading http://trac.gispython.org/projects/PCL/wiki/Shapely
Reading http://trac.gispython.org/projects/PCL/wiki/ShapeLy
Best match: Shapely 1.0.14
Downloading http://pypi.python.org/packages/2.5/S/Shapely/Shapely-1.0.14.win32.e
xe#md5=92281555b23623b8cf7b4fbc9d01f17a
error: Can't download
http://pypi.python.org/packages/2.5/S/Shapely/Shapely-1.0.14.win32.exe:
404 Not Found


2) How does one say "the latest release of sqlalchemy 0.5.x".
Unfortunately <0.6 picks up 0.6beta and I can see no way to do
wildcards in the docs and just say "give me the latest 0.5 series".

Thanks, Nick


More information about the Distutils-SIG mailing list