[Distutils] disutils2 and python 2.4

Maurits van Rees m.van.rees at zestsoftware.nl
Wed Mar 17 11:42:05 CET 2010

Op 17-03-10 11:16, Nicholas Bower schreef:
> I joined the list after this discussion:
> http://mail.python.org/pipermail/distutils-sig/2010-March/015607.html
> and want to point out that even the most recent versions of Zope 2.x for
> example still recommend Python 2.4.
> http://www.zope.org/Products/Zope/2.11.4/Zope-2-11-4-released

Except that at the top of http://www.zope.org/Products/Zope you will see 
that as of version 2.12 releases are made to the Python Package Index, 
at http://pypi.python.org/pypi/Zope2

To quote one of the changelog entries there: "Officially supporting 
Python 2.6 only (with inofficial support for Python 2.5) but dropping 
any support and responsibility for Python 2.4."

Note that the front of the www.zope.org now points to 
http://zope2.zope.org/ as a better source of information for Zope 2.

> In other words, there are probably alot of web apps out there (eg think
> about sites on Plone CMS) potentially running Python 2.4.  I run a
> dedicated Python 2.4 just for Plone for example (the buildout of which
> is based on virtualenv and setuptools anyway I guess).
> Whether distutils2 would be used by these projects of course is another
> matter.  Just pointing out Python 2.4 is absolutely not unimportant.

Agreed, I am in the Plone business and daily use Plone 3, which needs 
Zope 2.10, which needs Python 2.4.  The upcoming Plone 4 (first beta 
available) will use Zope 2.12, so will use Python 2.6, which is a good 

Maurits van Rees

More information about the Distutils-SIG mailing list