[Distutils] [Python-Dev] At least one package management tool for 2.7

Olemis Lang olemis at gmail.com
Wed Mar 24 13:27:03 CET 2010

On Wed, Mar 24, 2010 at 7:50 AM, Darren Dale <dsdale24 at gmail.com> wrote:
> On Wed, Mar 24, 2010 at 6:26 AM, Tarek Ziadé <ziade.tarek at gmail.com> wrote:
>> The open question is: do we want to include a full installer that
>> takes care of installing / removing dependencies as well ?
>> I think not. Pip already provides this feature on the top of distutils
>> (and distutils2 later I guess) and is not hard to install on the top
>> of Python.
> Is pip able to determine and install dependencies recursively, like
> easy_install does? Or is it up to the requested package to it specify
> its dependencies (and its dependencies dependencies) in a pip
> requirements file that is distributed separately?

My experience is that only `install_requires` is needed (unless you
want to create app bundles AFAICR) , but in practice I've noticed that
*some* easy_installable packages are not pip-able (though I had no
time to figure out why :-/ )



Blog ES: http://simelo-es.blogspot.com/
Blog EN: http://simelo-en.blogspot.com/

Featured article:
On adding Hessian (RPC) support for Trac -

More information about the Distutils-SIG mailing list