[Distutils] Recent buildout failure in Mailman 3

Barry Warsaw barry at python.org
Fri Oct 8 21:48:00 CEST 2010

I just got a new report of a buildout problem with Mailman 3.0a6.


The first part of the problem (corrupt eggs) was easily fixed.  It was caused
by a faulty MANIFEST.in that let eggs/ and parts/ leak into the tarball.
However, even with that fixed, buildout is failing for reasons I can't yet
figure out.  A full build is pastebin'd here:


I've tried pinning the setuptools version number < 0.6c12 and I've tried
pinning the logilab-common package to < 0.52, but neither workaround helps.  I
actually can't tell where the problem is: is it setuptools, distribute,
logilab-common or something else?  It *feels* like a bug in

Any thoughts?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20101008/d663579a/attachment.pgp>

More information about the Distutils-SIG mailing list