[Distutils] Recent buildout failure in Mailman 3

P.J. Eby pje at telecommunity.com
Sat Oct 9 05:30:44 CEST 2010


At 03:48 PM 10/8/2010 -0400, Barry Warsaw wrote:
>I just got a new report of a buildout problem with Mailman 3.0a6.
>
>https://bugs.edge.launchpad.net/mailman/+bug/656946
>
>The first part of the problem (corrupt eggs) was easily fixed.  It was caused
>by a faulty MANIFEST.in that let eggs/ and parts/ leak into the tarball.
>However, even with that fixed, buildout is failing for reasons I can't yet
>figure out.  A full build is pastebin'd here:
>
>http://pastebin.ubuntu.com/509012/
>
>I've tried pinning the setuptools version number < 0.6c12 and I've tried
>pinning the logilab-common package to < 0.52, but neither workaround helps.  I
>actually can't tell where the problem is: is it setuptools, distribute,
>logilab-common or something else?  It *feels* like a bug in
>setuptools-0.6c12dev.

I recently added symlink extraction support to 0.6c12dev; apparently 
it doesn't work with the symlink found in logilab-common.  (I'll have 
to investigate further to find out why.)

Older versions of setuptools simply didn't extract symlinks at all, 
so this problem didn't occur there.  I've put in a workaround ( 
http://peak.telecommunity.com/snapshots/setuptools-0.6c12dev-r85332.tar.gz 
) to fix the immediate issue (which is that an unextractable symlink 
causes an error), and next week I'll take a look at finding out why 
this *particular* symlink isn't extractable.

(Preliminary guess: the tarfile module doesn't support relative 
links, and thus needs some path fixup help from setuptools.)



More information about the Distutils-SIG mailing list