[Distutils] Distribute error? datetimewidget.pot: File name too long

P.J. Eby pje at telecommunity.com
Fri Sep 24 17:01:57 CEST 2010

At 02:45 PM 9/24/2010 +0100, Jon Hadley wrote:
>I'm trying to install a custom package in a buildout managed Plone 3 
>site in /develop-src named (for the sake of argument) 'foobar.wontbloodywork'.
>Yet I keep getting an error 'z3cform.datetimewidget.pot: File name too long'
>I get the same result on a freshly built Ubuntu server with no 
>previous eggs. The custom packages used to install fine in an older 
>(12 month +) project.
>It was suggested to me (via the Plone Users mailing list) that this 
>might be a distribute error. Can anyone on this list offer any insights?

Have you tried it using plain setuptools (0.6c11 or greater)?  There 
are some bugs in distribute regarding recursive build-time 
dependencies that were fixed in setuptools last October, but which 
are still outstanding in distribute.

 From your logs, it rather looks as though you've got a situation 
where collective.z3cform.datetimewidget has a build-time dependency 
on itself, so I'd like to know if setuptools can handle it correctly 
as well.  easy_installing the package directly works fine on my 
machine with setuptools; does distribute work for this as well?

If doing an easy_install or plain setup.py install works correctly 
with distribute, then the problem is probably in buildout rather than 
setuptools or distribute.  (I checked and the datetimewidget project 
(v1.0.2) does not declare any build-time dependencies, so there 
shouldn't be any recursion possible...  yet it appears to be taking 
place in your log nonetheless.)

More information about the Distutils-SIG mailing list