[Distutils] Distribute error? datetimewidget.pot: File name too long

Tarek Ziadé ziade.tarek at gmail.com
Fri Sep 24 17:13:30 CEST 2010

On Fri, Sep 24, 2010 at 5:01 PM, P.J. Eby <pje at telecommunity.com> wrote:
> At 02:45 PM 9/24/2010 +0100, Jon Hadley wrote:
>> I'm trying to install a custom package in a buildout managed Plone 3 site
>> in /develop-src named (for the sake of argument) 'foobar.wontbloodywork'.
>> Yet I keep getting an error 'z3cform.datetimewidget.pot: File name too
>> long'
>> I get the same result on a freshly built Ubuntu server with no previous
>> eggs. The custom packages used to install fine in an older (12 month +)
>> project.
>> It was suggested to me (via the Plone Users mailing list) that this might
>> be a distribute error. Can anyone on this list offer any insights?
> Have you tried it using plain setuptools (0.6c11 or greater)?  There are
> some bugs in distribute regarding recursive build-time dependencies that
> were fixed in setuptools last October, but which are still outstanding in
> distribute.

Please can you point us to the issue in the tracker and the commit
where that fix happened ?

I'd be glad to fix it if this happens to be true.

Tarek Ziadé | http://ziade.org

More information about the Distutils-SIG mailing list