[Distutils] Which buildout to use?

Reinout van Rees reinout at vanrees.org
Wed Aug 17 09:45:59 CEST 2011

On 17-08-11 04:23, Chris Withers wrote:
> Maybe pin numpy to the version provided by the system?
> Just a guess and nothing I've tried...

*Partial hurray sound*

Actually... that works. If I pin numpy to 1.5.1, buildout uses my 
site-packages one! We're one step further!

Next hurdle: I don't want to pin that package, as I don't particularly 
care which numpy version it is as long as it is recent enough. If I pin 
1.5.12, it'll be fine on my OSX machine, but ubuntu probably has a 
slightly different version. And our webserver might be hanging one 
ubuntu version back.

So: is there a way to *force* buildout to use the site-packages one, 
regardless of the version? (Provided it matches some minimum version 
requirement in case I provided one, of course). I can't find it in the docs.

osc.recipe.sysegg has a "force-sysegg" option that does just that.


Reinout van Rees                    http://reinout.vanrees.org/
reinout at vanrees.org             http://www.nelen-schuurmans.nl/
"If you're not sure what to do, make something. -- Paul Graham"

More information about the Distutils-SIG mailing list