[Distutils] [distribute] distribute_setup.py fails on Linux

Arve Knudsen arve.knudsen at gmail.com
Thu Feb 3 14:09:38 CET 2011

On Thu, Feb 3, 2011 at 1:52 PM, Tarek Ziadé <ziade.tarek at gmail.com> wrote:

> On Thu, Feb 3, 2011 at 1:47 PM, Arve Knudsen <arve.knudsen at gmail.com>
> wrote:
> > Hi Tarek
> > Nevermind, there was a problem with the Python installation so that it
> > didn't support zlib. Reinstalling Python fixed it :) Sorry for bothering
> > you. It might be an idea to embellish distribute_setup.py though, so that
> it
> > detects that Python can't untar the gzipped archive (due to missing zlib
> > support). That would've saved us some confusion at least :)
> > Arve
> Oh.. mmm I think this should even be addressed in tarfile if possible:
> if tarfile encounters a zipped archive, and zlib is not installed, it
> should not return a cryptic
> tarfile.ReadError: file could not be opened successfully
> But an error like
> tarfile.ReadError: archive not supported (zlib not installed)

Of course, tarfile *should* address this.

> And well, searching for this error in bugs.python.org, it looks like
> it will be addressed soon: http://bugs.python.org/issue8978

Nice surprise :) However, it'll only help with fixed versions of Python, no?
I figure distribute aims to support older Pythons as well.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20110203/96fd8ea5/attachment.html>

More information about the Distutils-SIG mailing list