[Distutils] using ZSQLMethods pypi package in zope 2.13

Fernando Martins fernando at cmartins.nl
Tue Jul 12 21:17:48 CEST 2011

On 07/11/2011 11:04 PM, Tres Seaver wrote:
[I just realised I had only replied to Tres]
>> Error: Picked: Products.ZSQLMethods = 2.13.4
> That error comes from having 'allow-picked-versions = false' in
> buildout.cfg -- you then need to supply an explicit version for every
> package.
My instance is out of buildout so I tried:

recipe = zc.recipe.egg
eggs = Zope2
     Products.ZSQLMethods >= 2.13.4

gives the same error and

Products.ZSQLMethods = 2.13.4

gives another error (I suspect "=" is not valid)

ValueError: ('Expected version spec in', 'Products.ZSQLMethods=2.13.4', 
'at', '=2.13.4')

I commented out allow-picked-versions and I got no errors. However, I 
got no ZSQL Method in zope.
> ...
> I think you want 'Products.ZSQLMethods' added to the 'eggs' value for
> your 'instance' section, so that it is on the sys.path when running the
> 'instance' script.
My instance is not in buildout and I would prefer to keep it separate, 
if possible. I tried [zopepy] because I saw it was making a custom 
sys.path with the eggs. ZSQLMethods is added to zopepy's sys.path but it 
does not appear in zope itself.

Do I need some extra configuration in the zope instance?

I installed ZMySQLDA in Products and it complained about missing 
Shared.DC.ZRDB. What to do to have the Sahred folder imported by Zope?


More information about the Distutils-SIG mailing list