[Distutils] using ZSQLMethods pypi package in zope 2.13

Leonardo Rochael Almeida leorochael at gmail.com
Wed Jul 27 00:52:53 CEST 2011

Hi Fernando,

Sorry for not being able to get to this earlier, but I didn't want to
leave your message unanswered.

It looks, from your message, that you haven't yet understood how to
specify packages and versions in a buildout configuration. It also
seems like you're trying to dismember python packages to attempt to
put directories in certain points of the hierarchy (like directories
in the Products folder).

I suggest you first read-up on zc.buildout and how it treats python
distributions[1], and then I suggest you simply use packages for
Products.ZSQLMethods and Products.ZMySQLDA, instead of trying to
dismember then and assemble them inside your Zope instance.

To do this, simply follow the tutorial at [2], but adding
Products.ZSQLMethods and Products.ZMySQLDA to the "eggs" parameter of
the section that defines the Zope instance. I've attached to this
e-mail one such buildout configuration for your convenience.

The tutorial at [2] has some easy-to-fix errors (like creating a
'logs' instead of a 'log' directory, and not creating the initial user
for the new Zope instance), but nothing you shouldn't be able to

And in case you're still stuck, I recommend you ask for help in one of
the Zope lists, since it's likely you'll be stuck in non-buildout
problems at that point.

[1] http://pypi.python.org/pypi/zc.buildout/1.4.4

[2] http://docs.zope.org/zope2/releases/2.13/INSTALL-buildout.html#creating-a-buildout-based-zope-instance



On Tue, Jul 12, 2011 at 21:17, Fernando Martins <fernando at cmartins.nl> wrote:
> On 07/11/2011 11:04 PM, Tres Seaver wrote:
> [I just realised I had only replied to Tres]
>>> Error: Picked: Products.ZSQLMethods = 2.13.4
>> That error comes from having 'allow-picked-versions = false' in
>> buildout.cfg -- you then need to supply an explicit version for every
>> package.
> My instance is out of buildout so I tried:
> [zopepy]
> recipe = zc.recipe.egg
> eggs = Zope2
>    Products.ZSQLMethods >= 2.13.4
> gives the same error and
> Products.ZSQLMethods = 2.13.4
> gives another error (I suspect "=" is not valid)
> ValueError: ('Expected version spec in', 'Products.ZSQLMethods=2.13.4',
> 'at', '=2.13.4')
> I commented out allow-picked-versions and I got no errors. However, I got no
> ZSQL Method in zope.
>> ...
>> I think you want 'Products.ZSQLMethods' added to the 'eggs' value for
>> your 'instance' section, so that it is on the sys.path when running the
>> 'instance' script.
> My instance is not in buildout and I would prefer to keep it separate, if
> possible. I tried [zopepy] because I saw it was making a custom sys.path
> with the eggs. ZSQLMethods is added to zopepy's sys.path but it does not
> appear in zope itself.
> Do I need some extra configuration in the zope instance?
> I installed ZMySQLDA in Products and it complained about missing
> Shared.DC.ZRDB. What to do to have the Sahred folder imported by Zope?
> Thanks,
> Fernando
> _______________________________________________
> Distutils-SIG maillist  -  Distutils-SIG at python.org
> http://mail.python.org/mailman/listinfo/distutils-sig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: buildout.cfg
Type: application/octet-stream
Size: 325 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20110727/c7f46aab/attachment.obj>

More information about the Distutils-SIG mailing list