[Distutils] unable to upload to pypi

Algis Kabaila akabaila at pcug.org.au
Wed Jul 27 13:58:25 CEST 2011

On Wed, 27 Jul 2011 05:49:17 PM Alan Franzoni wrote:
> On 07/27/2011 09:01 AM, Algis Kabaila wrote:
> > ak at supremo:/dat/work/py3/Matrix-Algebra$ python setup.py sdist upload
> I can't see Matalg on pypi.
> Have you tried registering before uploading? Can you see Matalg in the
> list of packages you own when you login into pypi website?
> python setup.py register sdist upload
> should do the trick.

No, I do not see Matalg registered - tried to search for it on the pypi 
website's search tool - not there.

Tried to register, but failed.  Removed the .pypirc script - it seems to me a 
convenience device.  Itis also a possible source of errors. A minor security 
risk, too.  The dialog is now:

ak at supremo:~$ rm .pypirc
ak at supremo:~$ cd /dat/work/py3/Matrix-Algebra/
ak at supremo:/dat/work/py3/Matrix-Algebra$ ls
COPYING.txt  dist  doc  MANIFEST  MANIFEST.in  matalg-mod  matalg-pdf  matalg-
rst  README.txt  setup.py
ak at supremo:/dat/work/py3/Matrix-Algebra$ python setup.py register
running register
running check
We need to know who you are, so please choose either:
 1. use your existing login,
 2. register as a new user,
 3. have the server generate a new password for you (and email it to you), or
 4. quit
Your selection [default 1]: 
Username: OldAl
Registering Matalg to http://pypi.python.org/pypi
Server response (400): Bad Request
ak at supremo:/dat/work/py3/Matrix-Algebra$ 

Clearly, the registration has failed.  I am bushed. If you can suggest 
anything else, I would dearly like to hear it.

Thank you for your attention and help,


More information about the Distutils-SIG mailing list