[Distutils] Distribute without 2to3

Lennart Regebro regebro at gmail.com
Tue Jun 21 14:42:04 CEST 2011

On Tue, Jun 21, 2011 at 13:30, Vinay Sajip <vinay_sajip at yahoo.co.uk> wrote:
> Lennart Regebro <regebro <at> gmail.com> writes:
>> We still need to support Python 2.4, right? That's a trickier issue.
>> But including six.py might help.
> I'm not sure why 2.4 is a particular issue.

It isn't. The big difference is between 2.5 and 2.6. But each
additional version brings it's own incompatibilities.

> I just tested on 2.4.6 without any
> failures. See
> https://gist.github.com/1037662

That's positive but...

> Of course, I'm assuming that "python setup.py test" gives adequate coverage.

It doesn't. Far from it, unfortunately.


More information about the Distutils-SIG mailing list