[Distutils] Distribute and Python 3.2

Jim Fulton jim at zope.com
Sat Mar 12 13:04:58 CET 2011


On Sat, Mar 12, 2011 at 6:05 AM, Vinay Sajip <vinay_sajip at yahoo.co.uk> wrote:
> I'm working on Python 3 versions of pip and virtualenv, with the idea of keeping
> a common codebase for Python 2.x and 3.x so as to make maintenance easier. To
> date, I've made good progress: My port of pip (working with my port of
> virtualenv) passes 100 tests (2 are skipped) on Python 3.2 and 3.3a0.

Yay!

> However,
> one roadblock is that distribute 0.6.14 doesn't work with Python 3.2 and later,
> because of the "abiflags" configuration parameter which is new in 3.2. Toshio
> Kuratomi has a fix for this checked in, and my tests have used a tarball of the
> distribute 0.6-maintenance tip with a name of distribute-0.6.15dev.tar.gz.
>
> It would be good if an official 0.6.15 release of distribute were made,
> incorporating that fix, now that 3.2 is out.

+1

I'm going to be working on a buildout port this week and will need a
Python 3.2-compatible port too!

Jim

-- 
Jim Fulton
http://www.linkedin.com/in/jimfulton


More information about the Distutils-SIG mailing list