[Distutils] zc.buildout 2.0.0a4 released

Chris Withers chris at simplistix.co.uk
Sat Dec 15 17:56:54 CET 2012

On 15/12/2012 09:33, Lele Gaifax wrote:
> Alex Clark <aclark at aclark.net> writes:
>> 19:43 < cullerton> Folks, there's something wonky going on with
>> buildout this morning. When I run bootstrap, it creates a buildout
>> script using buildout 2.0.
>> 0a4. This fails with an error (TypeError: get_dist() takes exactly 4
>> arguments (3 given)). Changing the version to buildout 1.4.4 seems to
>> fix things.
> FYI, I just met the same error (using 2.0.0a5), and the culprit was the
> buildout.dumppickedversion extension, that monkey-patches the
> easy_install.py::Installer._get_dist() method (it surprised me at first
> that the error message mentions “get_dist()” but at the referenced line
> in easy_install.py there is a call to “_get_dist()”...). It took a pdb
> session and a “p inspect.getmodule(self._get_dist)” to find out what's
> going on.

Yeah, the stuff that buildout.dumppickedversions and buildout_versions 
provide should just be in the core.

Jim, if I worked up a pull request would you merge it?



Simplistix - Content Management, Batch Processing & Python Consulting
            - http://www.simplistix.co.uk

More information about the Distutils-SIG mailing list