[Distutils] Distutils2: Does uploading to pypi work yet?

Todd DeLuca todddeluca at gmail.com
Sun May 27 17:19:18 CEST 2012

I recently failed to upload a project to pypi using distutils2 and failed
to install the project using pip.  Are distutils2 and pip not yet
supporting 'setup.cfg' only projects yet?

The upload failed to upload the tarball to pypi because of what looks like
a problem encoding a multipart form message with
distutils2.util.encode_multipart(). I tried to fix that problem (using a
base64 encoding) but ran into 500 http return code from the pypi server.
The uploading code seems pretty 'alpha', so I was wondering if anyone is
successfully using 'pysetup' to upload projects to pypi.

After failing to upload the distribtion, I uploaded it to github and then
registered my project with a github download url.  Then I tried installing
my project using pip and that failed too, since I did not have a setup.py,
only a setup.cfg, in the project.

I'm using python 2.7.3, pip 1.1, and distutils2 from
hg.python.org/distutils2 (pulled and updated) on Mac OS X 10.6.8.

Todd DeLuca
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20120527/04e7a864/attachment.html>

More information about the Distutils-SIG mailing list