[Distutils] $MACOSX_DEPLOYMENT_TARGET mismatch

Alan alanwilter at gmail.com
Wed Jul 3 15:55:17 CEST 2013

Hi there,

I am trying to install readline and cx_Oracle on my Mac OSX 10.8.4. I've
just installed python 2.7.3 standard in my $HOME dir and then I did:

export PATH=$HOME/bin:$PATH
python setup.py install --prefix=$HOME

which worked.

I tried to installed ipython 0.13.2 which seems to have worked but it fails
to start because of readline.

easy_install readline

         Searching for readline
Reading https://pypi.python.org/simple/readline/
Best match: readline
Processing readline-
Running readline- -q bdist_egg --dist-dir
error: Setup script exited with error: $MACOSX_DEPLOYMENT_TARGET mismatch:
now "10.3" but "10.4" during configure

How can solve this problem please?

Thanks in advance,


Alan Wilter SOUSA da SILVA, DSc
Bioinformatician, UniProt - PANDA, EMBL-EBI
CB10 1SD, Hinxton, Cambridge, UK
+44 1223 49 4588
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20130703/6bd3e8c6/attachment.html>

More information about the Distutils-SIG mailing list