[Distutils] zc.recipe.egg skips script-generation

Joe Steeve js at hipro.co.in
Wed Jul 3 22:57:51 CEST 2013

Hello all,

If this is not the right place to talk about 'zc.recipe.egg', please be
kind and point me to the right place :)

I am trying to create a buildout to work with some eggs using ipython. I
have a buildout.cfg like this:

        develop = .
        parts =
        recipe = zc.recipe.egg:scripts
        eggs =
        recipe = zc.recipe.egg:scripts
        dependent-scripts = true
        eggs =
        scripts = ipython

I have an ipython (0.13.1) installed in my system python's
site-packages. When I run buildout with the above, buildout simply says
"Installing ipython_part" and does not do anything else. If I remove my
system ipython (apt-get purge ipython), then buildout installs a script

I tried creating a virtualenv, and bootstrapping with the virtualenv's
python. I have the same effect.

How do I get an 'ipython' script with my desired eggs in its path?


Joe Steeve
HiPro IT Solutions Private Limited
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20130704/72810ac0/attachment.pgp>

More information about the Distutils-SIG mailing list