[Distutils] Setuptools 0.8 and Distribute 0.7.3 (legacy wrapper) now released

Reinout van Rees reinout at vanrees.org
Mon Jul 8 12:29:40 CEST 2013

On 05-07-13 20:05, Jason R. Coombs wrote:
> Additionally, Distribute 0.7.3 has also been released to PyPI.
> Distribute 0.7 was designed to ease the upgrade process from Distribute
> 0.6.x to Setuptools 0.7. This new version, 0.7.3, is a re-release of the
> legacy wrapper 0.7, but additionally bundles the Setuptools 0.8 code for
> the purposes of bootstrapping the upgrade. This version specifically
> eases upgrades on systems running older systems. Now, one can readily
> upgrade any environment with Distribute 0.6 by simply upgrading (using
> pip or easy_install) to Distribute 0.7.3, which will replace the
> ‘distribute’ package with an empty shell leaving setuptools >= 0.7
> (probably 0.8) installed.

I tried this on OSX and ran into a problem:

     $ sudo pip install -U distribute
     Downloading/unpacking distribute from 
       Downloading distribute-0.7.3.zip (145Kb): 145Kb downloaded
       Running setup.py egg_info for package distribute

     Downloading/unpacking setuptools>=0.7 (from distribute)
       Downloading setuptools-0.8.tar.gz (756Kb): 756Kb downloaded
       Running setup.py egg_info for package setuptools

     Installing collected packages: distribute, setuptools
       Found existing installation: distribute 0.6.28
         Uninstalling distribute:
           Successfully uninstalled distribute
       Running setup.py install for distribute

       Found existing installation: distribute 0.6.28
     Traceback (most recent call last):
"/Library/Python/2.7/site-packages/pip-1.1-py2.7.egg/pip/basecommand.py", line 
104, in main
         status = self.run(options, args)
line 250, in run
         requirement_set.install(install_options, global_options)
"/Library/Python/2.7/site-packages/pip-1.1-py2.7.egg/pip/req.py", line 
1129, in install
"/Library/Python/2.7/site-packages/pip-1.1-py2.7.egg/pip/req.py", line 
477, in uninstall
       File "build/bdist.macosx-10.8-intel/egg/pkg_resources.py", line 
1213, in get_metadata_lines
       File "build/bdist.macosx-10.8-intel/egg/pkg_resources.py", line 
1205, in get_metadata
       File "build/bdist.macosx-10.8-intel/egg/pkg_resources.py", line 
1270, in _get
     IOError: zipimport: can not open file 

So it downloaded 0.7.3 just fine, but barfed on a non-zipfile distribute 
0.6.28. The directory didn't exist afterwards, so I assume the upgrade 
process somehow removed it (or it got confused because it was or wasn't 
a zipfile).

Afterwards nothing pip-related worked as it missed setuptools.
The `/usr/bin/easy_install setuptools` also didn't work.

So I had to set it up anew, which worked:

     $ wget https://bitbucket.org/pypa/setuptools/raw/0.8/ez_setup.py
     $ sudo /usr/bin/python ez_setup.py


Reinout van Rees                    http://reinout.vanrees.org/
reinout at vanrees.org             http://www.nelen-schuurmans.nl/
"If you're not sure what to do, make something. -- Paul Graham"

More information about the Distutils-SIG mailing list