[Distutils] change in setuptools 8.0

Robin Becker robin at reportlab.com
Mon Dec 15 12:03:13 CET 2014

A bitbucket user informs me angrily that he cannot use the version of reportlab 
that's latest on pypi because it has a dependency


which is now treated as an 'and' condition by setuptools 8.0 so can not be 

In our latest code we have removed the '==2.0.0,', but presumably there's 
nothing I can do to make the situation less broken for older versions other than 
remove those from pypi.

Unfortunately we had this as part of the install_requires as

install_requires=['pillow ==2.0.0, >=2.4.0','pip>=1.4.1', 'setuptools>=2.2']

so it's our fault for being too lax in describing the requirement. Presumably 
the , in the list was always an 'and' and now the ',' in the elements is also :(
Robin Becker

More information about the Distutils-SIG mailing list