[Distutils] PEP440: foo-X.Y.Z does not satisfy "foo>X.Y"?

Paul Moore p.f.moore at gmail.com
Tue Dec 23 18:43:03 CET 2014

On 22 December 2014 at 20:44, Marcus Smith <qwcode at gmail.com> wrote:
> it would fail.  you'd need  ">1.7.0"
> On Mon, Dec 22, 2014 at 12:36 PM, James Bennett <ubernostrum at gmail.com>
> wrote:
>> So, if PyPI has foo-1.7 and foo-1.7.1, does ">1.7" just fail to find
>> anything installable?

I think the thing I'd missed, which makes this behaviour more
understandable (for me) is that you wouldn't usually get that in
reality. Projects tend to use a fixed number of digits in the version
number, so it'd likely be 1.7.0 and 1.7.1, and you'd be writing

Thinking of ">1.7" as "greater than the 1.7 series" sort of helps me as well...


More information about the Distutils-SIG mailing list