[Distutils] setup.py sdist not including my README.md

Joshua Richardson jricjr3 at gmail.com
Wed Jul 16 05:43:42 CEST 2014


Sorry for the Noob question, but I've been banging my head on this all
afternoon.

Following some tutorial I found somewhere on PyPI, I created a setup.py
which included a line like this:

# Get the long description from the relevant file

with open(path.join(here, 'README.md'), encoding='utf-8') as f:

    long_description = f.read()


and then in the setup() function, I pass


long_description=long_description


Somehow this worked, when I installed the package on my development box
(Mac with setuptools 5.1), so I prematurely published it to PyPI.
 Unfortunately, when I tried installing it to a fresh CentOS box
(setuptools 0.6c5-2.el5), I got this error:


Downloading/unpacking Dumper

  Downloading Dumper-1.0.1.tar.gz

  Running setup.py egg_info for package Dumper

.... <stacktrace omitted, let me know if you need it>

IOError: [Errno 2] No such file or directory:
'/tmp/pip-build/Dumper/README.md'

So, I checked the tarball and saw that README.md is not in there.  I read
the setuptools developer guide, and decided maybe I should try:

    include_package_data=True,

I re-ran "setup.py sdist" and checked the tarball, and the README.md is
still not in there.  Ok, maybe because my source-control is git.  So, I
added a MANIFEST.in, containing one line: "README.md".  Still no luck.  So,
I added:

    package_data={

        '': ['README.md'],

    },


Still a no-go.  Now I'm feeling stupid.  SOS.


Thanks for reading this far!   --josh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20140715/1ac9a908/attachment.html>


More information about the Distutils-SIG mailing list