[Distutils] Proposal: using /etc/os-release in the "platform tag" definition for wheel files

Matthias Klose doko at ubuntu.com
Fri Nov 28 16:31:40 CET 2014


On 11/28/2014 07:03 AM, Nick Coghlan wrote:
> We've discussed the idea of changing the wheel file naming scheme to
> deal with Linux previously, but never put together a concrete
> proposal.
>
> The closest we've got is the idea of allowing the platform tag to be
> customised in pip and perhaps bdist_wheel, and while that's good from
> an "enabling experimentation" perspective, it may be overkill if the
> primary goal is just to better support handling of Linux distros.
>
> For starters, here's the current definition of the platform tag in PEP 425:

hmm, maybe you repeat the rationale here for starters?

> =================
> The platform tag is simply distutils.util.get_platform() with all
> hyphens - and periods . replaced with underscore _ .
>
> * win32
> * linux_i386
> * linux_x86_64
> =================

this is already wrong for ARM32 soft-float and hard-float, and x86_64-linux-gnu 
and x86_64-linux-gnux32.  If something is changed, then please change that as 
well, maybe using something already defined like the multiarch triplet.



More information about the Distutils-SIG mailing list