[Distutils] Building and installing packages on a (unix) system lacking network accesss

KM nalani at fea.st
Tue Dec 22 08:51:04 EST 2015

Greetings distutils-sig,

I have a project with an autogenerated structure - that is, I ran a 
"helper" application which creates a directory structure and a setup.py 
for me. I am trying to build this package in a virtualenv on an isolated 
machine, necessiating the step of downloading all the prerequisite 
packages and making them available. I have done this and I can 
successfully install most of the prerequisites by passing "--no-index" 
and "-f <url>" to pip, making my full command-line:

pip install -e . --no-index -f <url>

This works up until a certain point, where pip (or something launched by 
pip) tries to download from the internet. I tried adding 
''--global-option '--no-index -f <url>'" to my options, but this failed. 
I get the error: option --no-index -f <url> not recognized. This occurs 
right after "Running setup.py install for TurboGears2" in the pip output 
and after it has installed a number of other packages. [Using 
--global-option was a shot in the dark, after all]. The package it is 
looking for is pytz. It appears to not be finding the package when it 
looks for it the first time - i.e., in the build log, it doesn't 
announce that it has found the package, it just moves on to the next 

The system is a FreeBSD 10.2 system, vanilla except for some packages 
like bash, python2.7 and well openjdk which installs a bunch of X stuff, 
unfortunately. It runs as a VM under VirtualBox (latest version) on 
Windows 8 (kept "up-to-date" but on version 8 not 8.1). The pip in use 
is 7.0.3 under python 2.7 (because that is the latest version of pip 
available in the FreeBSD ports).

I am hoping for some feedback or information that will allow me to 
install my application with all of its dependencies downloaded from a 
locally-available url or directory. Does anyone have any suggestions for me?


More information about the Distutils-SIG mailing list