[Distutils] Phantom release/file and now can't upload

James Bennett ubernostrum at gmail.com
Tue Jul 7 07:09:11 CEST 2015


Earlier tonight I was trying to upload a new version (1.1) of
https://pypi.python.org/pypi/django-contact-form

Initially tried 'setup.py sdist' followed by 'twine upload -s' of the
resulting tarball. Twine reported success, but no new release or file
appeared on PyPI. Tried 'setup.py sdist upload'. That reported success, but
no new release or file appeared on PyPI.

I tried quite a lot of things after that and kept getting reports of
success... and no new release or file on PyPI. I even went and copy/pasted
a sample from the distutils documentation using 'setup.py sdist upload -r'
to force PyPI just in case it was somehow using the wrong index.

Eventually some combination of things must have at least partly worked,
because information about a 1.1 release of django-contact-form appeared on
PyPI... except the file itself still did not appear, and any attempt to
upload returned:

HTTPError: 400 Client Error: This filename has previously been used, you
should use a different version.

I am absolutely stumped as to what's going on. I've tried deleting and
re-creating the 1.1 release to re-upload, but I'm stuck at being able to
create only an empty release with no file, since PyPI will not allow the
file to be uploaded.

While I try to track down what happened, who has the power to override
PyPI's disallowed filename restriction for this? As far as I can tell, the
file was *never* listed on PyPI and so could not have been downloaded by
anyone, and after struggling with this for a few hours I'm not at all in
the mood to bump versions just to get PyPI to cooperate.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20150706/1e48ebe0/attachment-0001.html>


More information about the Distutils-SIG mailing list