[Distutils] Phantom release/file and now can't upload

Richard Jones richard at python.org
Wed Jul 8 04:13:18 CEST 2015

Ah, sorry, I misunderstood. I believe I've removed the offending entry from
the database that's blocking you uploading. Please try again.


On 8 July 2015 at 09:28, James Bennett <ubernostrum at gmail.com> wrote:

> The 1.1 release exists, but PyPI thinks -- at least when it shows me the
> package-owner interface -- that there are no files for that release.
> Here's a screenshot of what I see:
> https://dl.dropboxusercontent.com/u/408510/django-contact-form-n-file.png
> Checked the 1.0 release just in case it went there, and that only shows
> the 1.0 package, not the 1.1 package.
> On Tue, Jul 7, 2015 at 4:23 PM, Richard Jones <richard at python.org> wrote:
>> This is very strange - perhaps there's a caching issue or something, but
>> there's a file present on that release when I look now :/
>> On 7 July 2015 at 15:09, James Bennett <ubernostrum at gmail.com> wrote:
>>> Earlier tonight I was trying to upload a new version (1.1) of
>>> https://pypi.python.org/pypi/django-contact-form
>>> Initially tried 'setup.py sdist' followed by 'twine upload -s' of the
>>> resulting tarball. Twine reported success, but no new release or file
>>> appeared on PyPI. Tried 'setup.py sdist upload'. That reported success, but
>>> no new release or file appeared on PyPI.
>>> I tried quite a lot of things after that and kept getting reports of
>>> success... and no new release or file on PyPI. I even went and copy/pasted
>>> a sample from the distutils documentation using 'setup.py sdist upload -r'
>>> to force PyPI just in case it was somehow using the wrong index.
>>> Eventually some combination of things must have at least partly worked,
>>> because information about a 1.1 release of django-contact-form appeared on
>>> PyPI... except the file itself still did not appear, and any attempt to
>>> upload returned:
>>> HTTPError: 400 Client Error: This filename has previously been used, you
>>> should use a different version.
>>> I am absolutely stumped as to what's going on. I've tried deleting and
>>> re-creating the 1.1 release to re-upload, but I'm stuck at being able to
>>> create only an empty release with no file, since PyPI will not allow the
>>> file to be uploaded.
>>> While I try to track down what happened, who has the power to override
>>> PyPI's disallowed filename restriction for this? As far as I can tell, the
>>> file was *never* listed on PyPI and so could not have been downloaded by
>>> anyone, and after struggling with this for a few hours I'm not at all in
>>> the mood to bump versions just to get PyPI to cooperate.
>>> _______________________________________________
>>> Distutils-SIG maillist  -  Distutils-SIG at python.org
>>> https://mail.python.org/mailman/listinfo/distutils-sig
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20150708/58ee7cef/attachment-0001.html>

More information about the Distutils-SIG mailing list