[Distutils] Towards a simple and standard sdist format that isn't intertwined with distutils

Paul Moore p.f.moore at gmail.com
Mon Oct 5 11:03:21 CEST 2015

On 5 October 2015 at 07:29, Nathaniel Smith <njs at pobox.com> wrote:
> First, let's drop the word "sdist", it's confusing.

I'll read your full reply later, when I have the time, but please note
we can't drop the term sdist - it's a well known concept in packaging.

Having said that, I'm happy if you want to restate your proposal in
terms of a new concept that's not a sdist (you'll need to come up with
a suitable term, and make it clear that it's distinct from a sdist
when you formalise the proposal, but that's OK for now).

My immediate thought is that I'm against a proposal that throws out
the sdist concept in favour of something new, as there's a lot of
reworking that would need to be done to achieve that, and I don't know
who's going to do that. So I'd need convincing that the proposal is
practical. For example, PyPI would need to be able to host these new
things, and distinguish between them and sdists.

But I'll hold off on detailed comments until I've read your full email.

More information about the Distutils-SIG mailing list