[PYTHON DOC-SIG] _using_ gendoc

Richard Jones richard.jones@bom.gov.au
Thu, 06 Mar 1997 13:39:21 EST

	OK, I'm confused.  I needed a nicely readable version of the SocketServer 
documentation, so I thought I'd give gendoc a bash.  Well, after getting 
strange errors (below) in import mode (sorry, I really don't have time to 
delve into the source), I tried the parsing mode.  I got a result, but 
_none_ of the embedded doc strings made it through...  So I tried running 
gendoc over itself (gendoc.py) and again, no docstrings - either in import 
mode or in parse mode!  Can anyone shed any light on my inability to use 
gendoc correctly?  Please? :)


> gendoc -d ../documentation /usr/local/lib/python/SocketServer.py
Traceback (innermost last):
  File "/usr/local/bin/gendoc", line 5, in ?
  File "/usr/local/lib/python/gendoc/gendoc.py", line 228, in main
    manpages = collect(args, formats, head)
  File "/usr/local/lib/python/gendoc/gendoc.py", line 270, in 
    manpages = doc_collect.gendoc(doc_collect.doc_collect(modules))
  File "/usr/local/lib/python/gendoc/doc_collect.py", line 685, in 
    return map(collector, module_list)
  File "/usr/local/lib/python/gendoc/doc_collect.py", line 664, in 
  File "/usr/local/lib/python/gendoc/doc_collect.py", line 533, in collect
    elif type(value) == ClassType and \
TypeError: not enough arguments

DOC-SIG  - SIG for the Python Documentation Project

send messages to: doc-sig@python.org
administrivia to: doc-sig-request@python.org