[docs] [issue10224] Build 3.x documentation using python3.x

Alexander Belopolsky report at bugs.python.org
Mon Nov 8 17:12:59 CET 2010

Alexander Belopolsky <belopolsky at users.sourceforge.net> added the comment:

As discussed on #python-dev, building  3.x documentation using python3.x will require Sphinx 1.1 which will not be released in time for 3.2.

I am adding #10225 as a dependency because I feel that fixing actual errors in ReST doctests is more important than upgrading documentation tool chain.  Hopefully this will bring more eyes to that issue.

This said, I believe it is important for python-dev to "eat their own dogfood" and make 3.2 self-hosting.  In other words, if we want to convince users that 3.x is ready, we should not require 2.x in the build process.

Fortunately, Doc/tools is not shipped with python releases, so the transition can be made at any time regardless of python release schedule.

dependencies: +Fix doctest runable examples in python manual
stage:  -> needs patch
type:  -> feature request

Python tracker <report at bugs.python.org>

More information about the docs mailing list