[docs] [issue1635217] Warn against using requires/provides/obsoletes in setup.py

Éric Araujo report at bugs.python.org
Wed May 16 20:17:12 CEST 2012


Éric Araujo <merwok at netwok.org> added the comment:

It may be good to document that requires/provides/obsoletes are effectively unused.

It is not appropriate for stdlib doc to talk about install_requires, which is specific to setuptools, and it’s better to talk about the new standard fields from PEP 345 anyway.

----------
components:  -Distutils2
keywords: +easy
resolution: out of date -> 
stage: committed/rejected -> needs patch
status: closed -> open
title: Add example of distutils setup() with "requires" argument -> Warn against using requires/provides/obsoletes in setup.py
versions: +Python 2.7, Python 3.2, Python 3.3

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue1635217>
_______________________________________


More information about the docs mailing list