[docs] [issue15964] SyntaxError in asdl when building 2.7 with system Python 3

Roger Serwy report at bugs.python.org
Sun Mar 31 22:01:33 CEST 2013


Roger Serwy added the comment:

I use Arch Linux which has /usr/bin/python as 3.3.0. I can confirm that "touch Include/Python-ast.h Python/Python-ast.c" fixes the problem. 

But would it have been simpler just to convert the print statements to functions so that asdl_c.py would work with Python 3 as well as Python 2?

----------
nosy: +roger.serwy

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue15964>
_______________________________________


More information about the docs mailing list