[docs] Improve the documentation in fcntl module (issue 18985)

ezio.melotti at gmail.com ezio.melotti at gmail.com
Sat Oct 19 06:41:33 CEST 2013

The patch looks good, but I see 3 different options about the names of
the args:
1) use opt for both -- this is simple and consistent, however opt sounds
to me like the abbreviation of option;
2) use the same name of the man pages -- closer to the original, but
more inconsistent;
3) use something like "operation" or maybe "oper" for both;

I don't have any strong preference, so unless there are reasons to
prefer options 2 or 3 I think the patch can be committed as is.

File Modules/fcntlmodule.c (right):

Modules/fcntlmodule.c:80: "fcntl(fd, opt, [arg])\n\
FTR, on the man pages opt is called "cmd".

Modules/fcntlmodule.c:309: "flock(fd, opt)\n\
On the man pages this is called "operation".
Is opt supposed to be the abbreviation of operation? option?


More information about the docs mailing list