[docs] [issue26459] Windows build instructions are very inaccurate

Maciej Fijalkowski report at bugs.python.org
Mon Feb 29 09:32:02 EST 2016


New submission from Maciej Fijalkowski:

I've tried following the dev guide (still not successful) to compile a debug version of cpython 2.7 and a couple issues that I run into:

* The VS2010 vs VS2008 confustion - the docs say "most versions before 3.3 use VS2008" - what does it mean by "most"? The current cpython trunk seems to work only on 2010 (with a variety of fun errors).

* VS2010 is hard to download, as is 2008 - direct links would help

* nowhere it's mentioned that you need to run stuff from VS console

* the readme and the devguide disagree on a few points - readme seems to be better, but also not ideal

* the docs don't say how to get svn.exe (that is install tortoiseHG, but then select extra tools from somewhere)

* the build seems to require perl, despite claiming it's not

Other things are misguiding too, but fixing all of the above would be a massive step forward

----------
assignee: docs at python
components: Documentation
messages: 261009
nosy: docs at python, fijall
priority: normal
severity: normal
status: open
title: Windows build instructions are very inaccurate
versions: Python 2.7

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue26459>
_______________________________________


More information about the docs mailing list