[docs] [issue27624] unclear documentation on Queue.qsize()
R. David Murray
report at bugs.python.org
Wed Jul 27 14:41:04 EDT 2016
R. David Murray added the comment:
The current wording is, IMO, better than the suggested wording, especially if you don't want to be "teaching stuff". The current wording is a specification of the method's behavior. I really don't know what you could replace "approximate" with that would improve it without having to get into a description of the behavior of a threaded program.
It seems like you are wanting us to document that the function will return an accurate size if the program is single threaded, but I don't think we want to do that, because that is not part of the specification of the method.
Python tracker <report at bugs.python.org>
More information about the docs