[docs] Correction for documentation reference

Michael Blankenship MichaelBlankenship.ftw at outlook.com
Sun Feb 10 12:55:39 EST 2019


There is some text in this page... https://docs.python.org/3/tutorial/controlflow.html#lambda-forms ...which indicates:

Name your classes and functions consistently; the convention is to use CamelCase for classes and lower_case_with_underscores for functions and methods.

Technically, the term camelCase (without other decoration) does not begin with a capitalized letter since it now looks like a camel with a hump in the middle. Given the potential for ambiguity there are two distinctions which more clearly identify what happens with the first character: UpperCamelCase and lowe​rCamelCase.

I'm also pretty sure lowercase is now a single word rather than two.

I would suggest reviewing and replacing with:

Name your classes and functions consistently; the convention is to use UpperCamelCase for classes and lowercase_with_underscores for functions and methods.

More information:  https://en.wikipedia.org/wiki/Naming_convention_(programming)#Python_and_Ruby
Naming convention (programming) - Wikipedia<https://en.wikipedia.org/wiki/Naming_convention_(programming)#Python_and_Ruby>
In computer programming, a naming convention is a set of rules for choosing the character sequence to be used for identifiers which denote variables, types, functions, and other entities in source code and documentation.. Reasons for using a naming convention (as opposed to allowing programmers to choose any character sequence) include the following:
en.wikipedia.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/docs/attachments/20190210/4ca13761/attachment-0001.html>


More information about the docs mailing list