[Email-SIG] Re: [I18n-sig] Re: [Mailman-Developers] Re: [Mailman-checkins] mailman/misc CJKCodecs-1.0.tar.gz, NONE, .cvsignore, 2.2, Makefile.in,, paths.py.in, 2.6, JapaneseCodecs-1.4.9.tar.gz, 2.1, NONE KoreanCodecs-2.0.5.tar.gz, 2.1, NONE

Anthony Baxter anthony at interlink.com.au
Tue Dec 30 22:58:11 EST 2003

>>> Barry Warsaw wrote
> But I do still think this is an appropriate patch for Python 2.3.x,
> since it really isn't a new feature.  This change should be appropriate
> whether you continue to use the old (and unsupported) Korean and Chinese
> codecs, with the alternative (and supported) Japanese codec, or whether
> you decide to use the combined CJKCodecs package.  At its heart the
> patch actually removes unnecessary dependencies on the separate Asian
> codec packages.  Since they all provide aliases, this will make the
> Charset.py file independent of the codec package being used.

I guess the deciding thing (for me) is that code written to use Python
2.3.4 (and the new codec work) should work on Python 2.3.x (x<4). I 
really don't want to see another repeat of the 2.2.2 fiasco (where 
code written for 2.2.2 wouldn't work on 2.2.1 or 2.2, because of the
new True/False objects). I've seen far, far too much code that's had
to do

      True, False
      True = 1
      False = 0


Anthony Baxter     <anthony at interlink.com.au>   
It's never too late to have a happy childhood.

More information about the Email-SIG mailing list