[Expat-bugs] [Bug #124390] File system filling when running configure on HP-UX 11.00

noreply@sourceforge.net noreply@sourceforge.net
Tue, 26 Dec 2000 08:03:37 -0800


Bug #124390, was updated on 2000-Dec-04 07:23
Here is a current snapshot of the bug.

Project: Expat XML Parser
Category: Build control
Status: Open
Resolution: None
Bug Group: None
Priority: 5
Submitted by: rtspotts
Assigned to : nobody
Summary: File system filling when running configure on HP-UX 11.00

Details: When trying to run the configure script on a HP-UX 11.00 system
/tmp is being filled with a pxdbXXXXXXX file.  The last check it runs is:
  
  checking for executable suffix

I've increased the amount of available space up to 500Meg+ and the file
keeps growing.  Any help would be appreciated.




Follow-Ups:

Date: 2000-Dec-26 08:03
By: rtspotts

Comment:
I guessing, but from the looks of it ltconfig is what's running at the time
of the file system filling.  It creates a group of PXDB files, but one is
always huge.  Here's a list of /tmp after it fills:

-rw-rw-rw-   1 root       sys            132 Dec 26 09:50 pxdbb05197
-rw-rw-rw-   1 root       sys              0 Dec 26 09:50 pxdbc05197
-rw-rw-rw-   1 root       sys              0 Dec 26 09:50 pxdbd05197
-rw-rw-rw-   1 root       sys              0 Dec 26 09:50 pxdbe05197
-rw-rw-rw-   1 root       sys              0 Dec 26 09:50 pxdbf05197
-rw-rw-rw-   1 root       sys        532953088 Dec 26 09:51 pxdbg05197
-rw-rw-rw-   1 root       sys              0 Dec 26 09:50 pxdbh05197


Here's a tail of the config.log file.  If you need more I'll email the
whole file.

configure:1012: checking if the linker (/usr/bin/ld) is GNU ld
configure:1028: checking for BSD-compatible nm
configure:1064: checking whether ln -s works
ltconfig:581: checking whether we are using GNU C
ltconfig:589: cc -E conftest.c
ltconfig:603: checking for object suffix
ltconfig:604: cc -c -g  conftest.c 1>&5
ltconfig:629: checking for executable suffix
ltconfig:630: cc -o conftest -g   conftest.c  1>&5
/usr/ccs/bin/ld: (Warning) At least one PA 2.0 object file (conftest.o) was
detected. The linked output may not run on a PA 1.x system

I am running as root when I run the configure script, unless I change alot
of system permissions I can't run it any other way.
-------------------------------------------------------

Date: 2000-Dec-18 21:43
By: fdrake

Comment:
This is *really* strange!  Do you know what program configure is running
when it creates the pxdb* file?  Can you send the config.log file configure
generates?

Thanks!
-------------------------------------------------------

Date: 2000-Dec-05 08:17
By: nobody

Comment:
This is a userid specific thing. I have the same problem 
(didn't get the reason for now). If i run configure as root, it works!
Maybe you've installed a OS Patch that kill's the system.
BUT i didn't got it running yet ...
-------------------------------------------------------

For detailed info, follow this link:
http://sourceforge.net/bugs/?func=detailbug&bug_id=124390&group_id=10127