[Expat-bugs] [ expat-Bugs-566088 ] php make fails @ libexpat.la on OSX

SourceForge.net noreply at sourceforge.net
Fri Jan 3 11:22:25 EST 2003


Bugs item #566088, was opened at 2002-06-07 21:23
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=110127&aid=566088&group_id=10127

Category: Build control
Group: Third-party Bug
Status: Open
Resolution: None
Priority: 5
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Greg Stein (gstein)
Summary: php make fails @ libexpat.la on OSX

Initial Comment:
hi all,

a build of php-latest (php4-200206071800) on OSX Server
10.1.4 with:

./configure --enable-shared --enable-static
--prefix=/usr/local/php4 --with-layout=PHP
--with-apxs2=/usr/local/apache2/sbin/apxs
--with-config-file-path=/private/etc/php4/
--mandir=/usr/local/man
--localstatedir=/private/var/php4
--x-includes=/usr/X11R6/include
--x-libraries=/usr/X11R6/lib
--with-expat-dir=/usr/local/expat
--with-mysql=/usr/local/mysql --with-openssl
--with-imap-ssl --with-mcrypt --with-mhash=/usr/local
--with-kerberos --with-imap=/usr/local/imap
--enable-mailparse --enable-magic-quotes --enable-ftp
--enable-force-cgi-redirect --enable-discard-path
--enable-inline-optimization --with-pear --with-zlib
--enable-calendar --disable-safe-mode --with-tsrm-pthreads

fails with:

.o Zend/zend_qsort.o Zend/zend_multibyte.o
Zend/zend_execute.o sapi/apache2filter/sapi_apache2.o
sapi/apache2filter/apache_config.o
sapi/apache2filter/php_functions.o
main/internal_functions.o -lcrypto -lssl -lc-client
-lexpat -lmysqlclient -lmhash -lmcrypt -lltdl -lz -lssl
-lcrypto -lbind -lm -ldl -lgssapi_krb5 -lkrb5
-lk5crypto -lcom_err -ldl -o libs/libphp4.bundle && cp
libs/libphp4.bundle libs/libphp4.so
/usr/bin/ld: warning -L: directory name (/lib) does not
exist
/usr/bin/ld: /usr/local/expat/lib/libexpat.la bad magic
number (not a Mach-O file)
make: *** [libs/libphp4.bundle] Error 1

expat build went fine on OSX, with:

cd expat-1.95.3;
./configure --prefix=/usr/local/expat
--mandir=/usr/local/man --x-include=/usr

to be used by a number of other progrs successfully ......

any thoughts/suggestions on either would be much
appreciated!

fyi, details of my environment are doc'd on my
web-page, below .....

thanks!

richard


--------------------------------------
R Blake
blakers <at> mac.com
http://homepage.mac.com/blakers
--------------------------------------

----------------------------------------------------------------------

>Comment By: Greg Stein (gstein)
Date: 2003-01-03 11:22

Message:
Logged In: YES 
user_id=6501

This may be caused by an old version of libtool being used
to create the tarball. Please try rebuilding the libtool
scripts by running the "buildconf.sh" script found in the
top-level dir of the distribution. Make sure that your OSX
box has the "correct" libtool. (I'm not sure where that can
be found, but I do know that libtool has had problems on OSX)

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=110127&aid=566088&group_id=10127



More information about the Expat-bugs mailing list