[Expat-bugs] [ expat-Bugs-1237648 ] detected recursion whilst expanding macro "XML_STATUS_ERROR"

SourceForge.net noreply at sourceforge.net
Sat Jul 16 10:20:10 CEST 2005


Bugs item #1237648, was opened at 2005-07-13 12:10
Message generated for change (Comment added) made by kwaclaw
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=110127&aid=1237648&group_id=10127

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Build control
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Greg Stein (gstein)
Summary: detected recursion whilst expanding macro "XML_STATUS_ERROR"

Initial Comment:
Hi all, 

I got a problem in installing expat 1.95.7 on Mac os X (darwin). 

./configure run ok.

make gave one error:

/bin/sh ./libtool --silent --mode=compile cc -g -O2 -Wall -Wmissing-
prototypes -Wstrict-prototypes -fexceptions -
DHAVE_EXPAT_CONFIG_H  -traditional-cpp -I./lib -I. -o lib/
xmlparse.lo -c lib/xmlparse.c
lib/xmlparse.c:918: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
lib/xmlparse.c:924: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
lib/xmlparse.c:926: error: detected recursion whilst expanding 
macro "XML_STATUS_OK"
lib/xmlparse.c:1157: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
lib/xmlparse.c:1162: error: detected recursion whilst expanding 
macro "XML_STATUS_OK"
lib/xmlparse.c:1404: error: detected recursion whilst expanding 
macro "XML_STATUS_OK"
lib/xmlparse.c:1408: error: detected recursion whilst expanding 
macro "XML_STATUS_OK"
lib/xmlparse.c:1411: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
lib/xmlparse.c:1466: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
lib/xmlparse.c:1488: error: detected recursion whilst expanding 
macro "XML_STATUS_OK"
lib/xmlparse.c:1493: error: detected recursion whilst expanding 
macro "XML_STATUS_ERROR"
make: *** [lib/xmlparse.lo] Error 1

can someone give me a help. Thanks very much. 

chenhong

----------------------------------------------------------------------

>Comment By: Karl Waclawek (kwaclaw)
Date: 2005-07-16 04:20

Message:
Logged In: YES 
user_id=290026

Which compiler are you using?
Try to update the compiler, if possible.


----------------------------------------------------------------------

Comment By: Nobody/Anonymous (nobody)
Date: 2005-07-15 12:59

Message:
Logged In: NO 

I actually tried with expat1.95.8
Still have the same problems

thanks




----------------------------------------------------------------------

Comment By: Karl Waclawek (kwaclaw)
Date: 2005-07-15 12:57

Message:
Logged In: YES 
user_id=290026

Looks like a compiler issue.
Check out bug # 1171968.

Switch to gcc, if possible.

----------------------------------------------------------------------

Comment By: Nobody/Anonymous (nobody)
Date: 2005-07-15 12:12

Message:
Logged In: NO 

I actually tried with expat1.95.8
Still have the same problems

thanks




----------------------------------------------------------------------

Comment By: Nobody/Anonymous (nobody)
Date: 2005-07-15 12:06

Message:
Logged In: NO 

I got the same exact problem when building on OPTERON
Any ideas will be welcome
thanks

----------------------------------------------------------------------

Comment By: Karl Waclawek (kwaclaw)
Date: 2005-07-13 15:02

Message:
Logged In: YES 
user_id=290026

Does it work allright with Expat 1.95.8?

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=110127&aid=1237648&group_id=10127


More information about the Expat-bugs mailing list